Shape Effects

Shape Effects

A shape effect is a geometric distortion or modification of the shapes in a group of objects. Shape effects are used to create various visual adjustments or effects of object shapes, or to create shape variations by distorting shapes.

Shape effects can be used to reshape objects or a group of objects, without permanently altering the original geometry of these objects. Shape effects are parametric and nondestructive attributes added to an object, a group or a whole layer.

  • Nondestructive means that shapes are not converted to curves, instead a final object shape is obtained from the original parametric shape, combined with a series of shape effects stacked on the object.
  • Parametric means that the attributes specific to a shape effect can be modified at any time, after an effect is applied on an object. This includes the possibility to alter shape effect attributes if there were other shape effects applied over the object.

Some important aspects to consider when working with shape effects:

  • Shape effects alter the shape of objects. Images, patterns and gradients are not distorted by default. Tiling patterns can be distorted with shape effects, by enabling the Apply Shape Effects pattern option.
  • Object transformations (scaling, skewing and rotating) are handled as shape effects. Transformations will be applied to images, patterns and gradients by default, but this can be disabled.
  • Past transformations of an object can be accessed and modified in the Shape Effects panel and editor.
  • Multiple shape effects can be stacked on an object, group or layer. Each effect distorts the shapes resulting from the previous effect. Attributes of stacked shape effects remain editable.
  • Distortion effects (Mesh, Envelope, Bend) are geometric effects distorting the space inside the bounding box of an object, group or layer. Groups or layers of objects are distorted as a single geometry containing multiple shapes. It is possible to add or modify objects of a distorted group.
  • The expanded stroke area can also be distorted using shape effects, by enabling the Filtered Outline option of the stroke. The original stroke remains in place, and the stroke attributes remain editable. The stroke is expanded only to obtain the final, displayed object shape.
  • Shape effect attributes can be adjusted visually, using the shape effect tool from the Shape Effects panel. For example, the rotation amount of the Twirl effect can be adjusted visually, by dragging the twirl handle around the object.
  • Shape effects can be grouped, and saved as a single preset or style. Shape effect presets and styles can be applied on objects from the Shape Effects panel or editor.
  • When shape effect styles are used on objects, modifying the style will modify all objects using that style.
  • To access and edit the shapes resulting from the use of shape effects, convert the object, group or layer to curves using the Convert to Curves command from the Object menu.

Overview

Creating and editing shape effects depends on the type of the shape effect and the choice of tools. These are described in the following sections:

  • Shape Effects Panel - Describes how to use the shape effect panel to create and edit shape effects on selected objects. The shape effect panel provides the easiest access to the attributes of shape effects.
  • Shape Effects Editor - Describes how to use the shape effect modal editor, to create and edit a set of shape effects. The modal editor can be used to create and edit shape effects of the selected objects, or to edit shape effect styles or presets.
  • Distortion Effects - Contains the description of the shape effects in the Distortion group of effects. These are shape effects modifying the shapes using some form of parametric spacial distortions.
  • Mesh Effects - Contains the description of mesh based shape effects. These are shape effects under the Mesh and Warp group, that distort the object shapes using some form of mesh.
  • Outline Effects - Contains the description of the shape effects in the Outline group. This includes interactive outline offsetting.
  • Shape Effect Brushes - Describes how to use shape effect brushes to paint shape distortions on selected objects.

Creating Effects

The recommended way of adding a new shape effect to an object is to use the Shape Effects panel.

  • Select the object to be distorted by a shape effect.
  • If multiple objects are distorted with a single shape effect, select the objects and group them.
  • Open the Shape Effects panel from the Panels - Effects menu.
  • Click on the button in the icon section of the Shape Effects panel. A menu of available shape effects is opened.
  • Select the shape effect from the menu opened from the panel.
  • The shape effect is applied on the selected object using default attributes.
  • If there are multiple objects selected, these will be automatically grouped when a shape effect is applied.
  • Adjust the shape effect attributes in the panel. It may be necessary to open the shape effect attributes in the panel, using the arrow button shown before the shape effect name. See the Shape Effects Panel section, for more details on how to use the panel.
  • Use the or buttons to visually adjust shape effect attributes, depending on the shape effect type.

Alternative ways to apply shape effects on an object are:

  • Select the shape effect from the Effects menu of the application. A modal view is opened, to edit the shape effects applied on an object. Setup one or more shape effects with attributes, and confirm by pressing Ok. For more details on the modal shape effect editor, see the Shape Effect Editor section.
  • Select a shape effect tool from the application toolbox. The shape effect tool will create a new shape effect on a clicked object, if the last shape effect on that object is not the selected effect. Otherwise, the tool will adjust the existing shape effect.
  • Double click on a previously created shape effect preset in the Presets panel.
  • Double click on a previously created shape effect style in the Styles panel.
  • Copy and paste shape effects between objects, using the Copy Shape Effect and Paste Shape Effect commands from the Edit menu.
  • Pick and apply shape effects using the Shape Effect Picker tool.

Modifying Effects

Attributes of shape effects previously applied on an object can be modified, using the Shape Effects panel, editor or tools.

  • Select the object containing the shape effects.
  • Open the Shape Effects panel from the Panels - Effects menu.
  • The panel will show the list of shape effects from the selected object.
  • Open the attributes of a shape effect, using the arrow button, if not already opened.
  • If there are many shape effects, or large attribute sections, the panel content can be scrolled, or the panel resized, to access attributes of an effect.
  • Select a shape effect, by clicking on the effect name in the list of shape effects.
  • Edit the shape effect specific attributes, by adjusting the options shown under a shape effect name.
  • By default, only the most common attributes of a shape effect are shown. Use the button, shown at each shape effect name, to select more detailed attributes.
  • Use the or buttons to visually adjust the selected shape effect attributes, depending on the shape effect type.
  • Alternatively, select the Edit Shape Effects command from the Effects menu, to modify and organize the shape effects of the selected object, in a modal editor.

Shape Effect Brushes

A number of shape effects creating geometric distortions are available as shape effect brush tools from the application toolbox (the tool and similar).

When using shape effects as a brush, only a restricted region of the object shapes are distorted. The size of this region depends on the brush size.

The shape effect brushes are destructive, the object shapes will be converted to curves and modified according to the shape effect type and options.

To adjust object shapes with a shape effect brush, use the following steps:

  • Select the objects to be adjusted. Select multiple objects to distort their shapes. The objects will not be grouped.
  • Select a shape effect brush tool from the application toolbox, grouped with the tool. See the Shape Effect Brushes section, for the available effect brush tools.
  • Adjust the shape effect brush size and options, by double clicking on the tool icon in the application toolbox.
  • Paint with the brush over the selected objects.
  • The selected objects are converted to curves, and their shapes are adjusted according to the brush type and options.

Examples

Some examples of shape effects and their attributes are shown next:

Editable Twirled Text

When effects are applied to shapes of vector objects, both the shapes and the effects remain editable. In this example a text shape is distorted using the Twirl effect. The text can be highlighted and modified using the Shape Text tool, while the twirl effect distorts the text.

Shape text with twirl effect can be edited.

Elastic Warp on Groups

In the elastic warp effect (described in the Mesh Effects section), pin point locations of an object or group are moved, and the shapes are distorted according to an elastic stretching of the object geometry.

When using elastic warp on a group of objects, or a layer, the whole group is treated as a single object. Pin points can be added inside the bounding box of an object at any locations, to create elastic distortions.

Elastic warp distorts groups as a single object.

Envelope Corners

In the envelope distortion (described in the Mesh Effects section), an object, group or layer is stretched into a user created shape.

Envelope shapes can be selected from any closed shape preset, style or object reference. Using object references with the Shape role, as envelope shapes, enables the editing of the envelope shape by editing the original shape.

The envelope mapping tool, accessed with the tool of the Shape Effects panel, can be used to move the four corners of the object bounding box along the envelope shapes to any location.

The four corners of an object or group, are mapped to locations along the envelope shape.

Bending Groups

In the bend distortion (described in the Mesh Effects section), an object, group or layer, is bent along the shape, while stretching the object using a variable width profile.

The shape used in bending can be any open or closed shape. Shape presets or styles can be selected to reuse shapes. Object references with the Shape role can be used to set the bending shape to the shape of an object.

The bending shape can be edited interactively using the button from the Shape Effects panel. The bending shape is edited in a similar way as an object shape.

The variable width profile used to stretch the bent objects, can be edited interactively using the button from the Shape Effects panel.

Interactive editing of the variable width profile used in a bend distortion.

Offsetting shapes

In the Offset Shape effect (described in the Outline Effects section), an object shape is expanded or reduced using a shape offset distance.

The shape offsetting distance can be edited interactively using the button from the Shape Effects panel.

The Offset Shape effect uses variable width profile, to create variable distance offsets along the shape. Local distances can be created and adjusted using the offset shape editor tool.

Interactive editing of the variable shape offsets.