Layers and Objects

Layers and Objects

A VectorStyler document contains a hierarchy of canvases. Canvases can be used to create and reuse multiple illustrations, symbols and styles. When a new document is created, a single regular canvas is added to the document for creating the artwork. An initial reference and a master canvas is also added to enable a better work flow in the document.

Each canvas contains a hierarchy of layers and objects, that define the artwork placed on the canvas. Objects are the main components used to make up an illustration. An object can have a shape and several fill and outline styling attributes. An object may contain other objects, creating groups of objects. An object with a shape containing other objects is also known as a clipping group. Objects can be selected using various selection modes, including a simple click with the mouse. Selected objects can be styled and changed using various editing features of VectorStyler.

Layers are similar to objects with a few extra properties, and some special treatment in the user interface. The top level objects of a canvas are typically layers. A layer may contain several sub-layers or a collection of objects. Layers and objects may mix inside a layer. This enables the buildup of a hierarchy of layers and objects used to organize the structure of an illustration. An object cannot contain a layer.

Overview

This chapter describes various common layer and object editing features as follows:

  • One of the most common operations when working with a vector illustration is to select and Transform Objects.
  • VectorStyler keeps track of all changes made on a document. A change can be undone and then redone if required. The Undo and Redo section describes how to work with the document change history. After undoing some changes, new changes may be applied, creating an alternate history of the document. These alternate histories can be browsed and activated using the History panel.
  • The layer and object hierarchy draws the objects in a specific order of appearance. This order can be changed using the various object arrangement commands described in the Arranging Objects section.
  • Objects can be positioned relative to each other using various geometric alignments. This includes aligning objects along a path. The Aligning Objects section describes the various alignment options available to position and transform objects.
  • The appearance of layers and objects is controlled by various options. These can be set from the Layers panel, or with the Object Options command.
  • Objects can be cloned, where the clones inherit some of the attributes of a main (master) object. Creating clones is similar to duplicating objects. Working with cloned objects is described in the Cloning Objects section.
  • Objects can be referenced, creating symbolic links to an object and placing it at arbitrary location (or another canvas). Creating references to objects results in Symbols. The details of creating references to objects is discussed in the Referencing Objects section.
  • Managing the hierarchy of layers and objects on a canvas can be done using the Layers panel. The Layers Panel section describes how to work with layers, and how to open multiple Layers panels to navigate different parts of the document.
  • Objects may contain multiple fill and stroke style attributes, each with its own transparency settings and local effects. Managing the styles associated with an object is described in the Object Styling section.
  • Image effects can be applied to a backdrop of a layer or an object, resulting in Adjustment Effects. The use of Adjustment Effects by whole layers, or restricted to the shape of an object, enables the creation of complex visual appearances.
  • Objects styled with various attributes can be expanded into editable shapes or constituent objects. The Expanding Objectxs section describes how to expand various object types.
  • Object and layer naming is an important feature when working with complex illustrations, including creating and using symbols and styles. The various object naming features are described in the Renaming Objects section.

Styling Layers

A layer cannot be directly selected using the regular selection tools. By default layers have no shape and act as a group of objects opened for selection and editing. When using selection tools, the content of the layers are searched for objects matching the selection criteria.

Since layers are just like objects (and share the internal representation in VectorStyler), they can be selected indirectly by selecting them in the Layers panel using the selection widget shown at the right side of each layer and object item (see the Layers Panel for more on this).

When a layer is selected, it can be changed just like any other object. This includes applying transformations or effects, setting a shape to the layer and (once a shape is set) setting up one or more fill and outline styles. When a shape is assigned to a layer, the content of a layer will be clipped into the shape.

Setting up a shape for a layer enables the quick and easy creation of clipped object collections (that are readily available for selection), and the creation of adjustment effects over restricted areas.

The hierarchy of layers and objects can be managed using the Layers panel.

Locking Objects

An object can be locked to avoid any further modifications. A locked object remains visible, but cannot be selected or modified.

  • To lock an object, select the object (or the objects) and select the Locked command from the Object menu.
  • The object (or objects) will be locked and cannot be modified or selected.
  • Locked objects can be unlocked by selecting them using the Select all Locked command in the Select menu and then selecting the Locked command of the Object menu (to uncheck the locked option).
  • Another way to unlock a locked object is to use the Layers panel and click on the lock icon.

Hiding Objects

Objects can be hidden to remove them from the artwork, without actually deleting the object. A hidden object remains editable, but it cannot be selected with the typical selection tools.

  • To hide an object, select the object and select the Hidden command from the Object menu.
  • To select all hidden objects, use the Select all Hidden in the Select menu.
  • To select a specific hidden object, use the Layers panel selection tools.